Сообщения

Сообщения за Сентябрь, 2017

Настройка Mikrotik + Yota 4g, LTE.

Изображение
Оборудование:
Модем от Yota (LU150 4G LTE)
Тестовая модель RouterBOARD RB751U-2HnD с версией RouterOS 5.17 Подключите модем к выключенному маршрутизатору. После этого включите маршрутизатор. При подключении к работающему маршрутизатору возможно не появится интерфейс LTE
При подключении 4G модема lte интерфейс создается автоматически. Обратите внимание, что интерфейс нужно активировать, по умолчанию он выключен.
Добавим DHCP-клиент для этого интерфейса

А также, правило NAT


Либо командами через терминал напишем:
/ip dhcp-client add disabled=no interface=lte1
/ip firewall nat add action=masquerade chain=srcnat out-interface=lte1 to-addresses=0.0.0.0 После этого на интерфейса lte1 появится IP адрес, и заработает интернет. Примечание: Перед покупкой модема рекомендуем ознакомиться.

Как сделать RAID-1 массив на Ubuntu

Изображение
Опишем здесь процесс создания Raid-1 (зеркального) массива на Ubuntu.
Для создания RAID-1 нам необходимо как минимум 2 диска (желательно одного размера). Чтобы создать  RAID массив воспользуемся утилиткой mdadm.
Установка mdadm:

apt-get install mdadm

Во время установки попросит указать настройку для postfix, выбираем «без настройки»,  либо ту которая вам нужна.
Далее подготавливаем наши диски: (Список дисков можно посмотреть командой)

fdisk -l

Необходимо подготовить разделы на наших дисках
После того, как разделы созданы соберем из них RAID1

mdadm --create --verbose /dev/md0 --level=1
--raid-devices=2 /dev/sdb1 /dev/sdc1

где, —create — указываем что мы создаем raid массив

/dev/md0 — имя нашего создаваемого raid-массива

—level=1 — указываем вид RAID. В нашем случае он зеркальный то есть — 1

—raid-devices=2 — кол-во устройств в raid-массиве

/dev/sdb1 /dev/sdc1 — указываем 2 наших диска из которых мы собираем raid

Если все успешно, то мы увидим примерно следующее:

# mdadm --create --verbose /dev…

Mikrotik — настройка IPTV (igmp-proxy)

Изображение
Для того чтоб настроить IP-TV на маршрутизаторе Mikrotik, необходимо включить пакет multicast. , Если пакет уже установлен, то в консоли маршрутизатора в который вы зашли  через Winbox или Web-интерфейс, в разделе Routing, будет доступен пункт Igmp-Proxy.
Итак начнем:

Нам требуется устанавить quick-leave в положение yes, это позволит ускорить переключение между каналами. Очень полезная вещь и мы  сбережем свои нервные клетки и не разочаруемся в нашем девайсе. Далее нам требуется добавить интерфейсы: bridge — в моем случае локальная сеть, ether1 — интерфейс подключения к провайдеру.

Консольные команды для описанного выше:

routing igmp-proxy set quick-leave=yes
routing igmp-proxy interface add interface=bridge
routing igmp-proxy interface add interface=ether1 alternative-subnets=0.0.0.0/0 upstream=yes

Правила firewall необходимо переместить в верх списка, выше правила drop и всех пакетов в цепочках incput и forward.
В правиле цепочки forward, необходимо указывать dst-port номер порта на ко…

Почему лучше использовать Python в качестве первого языка программирования.

Изображение
Чтобы начать понимать Python достаточно хотя бы немного знать английский язык. Как показывают исследования Ассоциации Вычислительной Техники, язык Python занимает лидирующие позиции в качестве первого языка программирования во многих американских колледжах. По опросу 39 передовых IT факультетов США, он сместил Java и стал первым языком программирования общего назначения, на который обращают внимание начинающие программисты. 8 из 10 передовых IT факультетов (80%) и 27 из 39 (69%) преподают Python на первых этапах изучения профессии. Сам язык был создан 23 года назад, но как отличный инструмент для обучения новичков программированию, его открыли совсем недавно. Так же Raspberry Pi оказал свое влияние на Python, но и не стоит забывать о том, что Python применяется ведущими компаниями мира, а именно Google, Yahoo и Nasa, что делает его привлекательным и для разработчиков с опытом за плечами. В настоящее время Python занимает устойчивое положение среди восьми самых популярных языков программ…

Несколько отличий между Java и javascript.

Изображение
Языки Java и JavaScript очень похожи между собой  но и отличаются, в зависимости от того, как на них посмотреть. Первое это история их создания:язык Java является языком объектно-ориентированного программирования (ООП), созданным Джеймсом Гослингомв Sun Microsystems. JavaScript — это язык сценариев, который был создан группой людей в Netscape и первоначально назывался LiveScript. JavaScript является очень дальним родственником Java лишь в том, что это тоже язык ООП. Во многом их синтаксис похож. Однако JavaScript содержит гораздо меньше и более простые команды, чем язык Java. Второе, главное отличие.Оно состоит в том, что программа, написанная на Java,может применяться самостоятельно, в то время какJavaScript должен быть размещён внутри HTML документа. Java намного универсальнее и сложнее, на этом языке создают «автономные» приложения. Ява «апплет» является полностью законченной программой. JavaScript — это текст, который подается браузеру, чтобы тот интерпретировал его. Третье, взаимодейств…

Как проверить видеокарту на наличие ошибок.

Изображение
Если во время работы за компьютером у вас случаются сбои в играх или других графических приложениях, требуется обратить внимание на видеокарту. Причины бывают разные, некоторые можно удивить воочию, некоторые только при помощи специализированного программного обеспечения.
Первое на что стоит обратить внимание это на конденсаторы видеокарты. Если вы увидите вздутый конденсатор, то надо обратиться в специализированный сервисный центр. 
Если все конденсаторы целые и видеокарта в тщательном рассмотрении выглядит хорошо значит надо копать глубже.
Далее надо проверить перегревается ли видеокарта, а так же проверить драйвер видеокарты.
Стоит обратить особое внимание и на то, что если вы увлекались оверлоком и пытались увеличить производительность за счет программного обеспечения, то проблема очевидна :) Это перегрев видеочипа. Определить это можно даже по скорости вращения  и шуму вентилятора, а так же программой aida64
Если вы не увлекались оверлоком, стоит переустановить драйвер видеокарты ск…

Установка Active Directory Domain Services на Windows Server 2012 R2

Изображение
Данное руководство предназначено для тех, у кого есть желание самостоятельно установить роль Active Directory Domain Services на Windows Server 2012 R2. В этом руководстве мы будем рассматривать тот случай, когда у вас уже есть сервер с установленной на нем операционной системой Windows Server 2012 R2. Рекомендую всегда использовать англоязычные издания Windows Server. Как показывает практика, оригинальные (английские) версии Windows работают стабильнее, к тому же вам будет проще общаться на одном языке с профессионалами в случае возникновения проблем или при желании обменяться опытом.

Случайное удаление файлов рута

Вы спокойно блуждаете по директории $HOME, думая о своих делах.

$ whoami
> user

$ pwd
> /home/user

Но что-то вас беспокоит. Это как маленький камушек (little rock), попавший в ботинок. Вы снимаете обувь, чтобы посмотреть, в чём дело.

$ ls -lah ./left-shoe
---------- 1 root root 4 May 30 13:20 little-rock

Странно. Он здесь, но как будто не принадлежит вам. Его оставил root, Рок Теймер, и только он решает его судьбу.

Ubuntu MySQL — свободная СУБД для малых и средних приложений.

Изображение
УстановкаMySQL есть в репозиториях Ubuntu. Он разбит на несколько пакетов.
Для того чтобы установить MySQL сервер выполните команду:

sudo apt-get install mysql-server

При установке конфигурационный скрипт запросит пароль для администратора (root) базы данных.
Для того чтобы установить консольный клиент MySQL выполните команду:

sudo apt-get install mysql-client

Для того чтобы установить модуль для работы с MySQL в PHP выполните команду:

sudo apt-get install php5-mysql

Язык структурированных запросов SQL

Изображение
SQL (StructureQueryLanguage) – является общепринятом языком написания запросов к реляционной базе данных. Не является языком программирования и СУБД, т. к. не содержит команд создания интерфейса, а имеет только команды обработки данных. SQL запрос - команды, написанные на языке SQL Способы применения SQL в прикладных программах: 1.Встроенные – SQL запрос записываются в тексте программы. Компиляция приложения специальным перепроцессором SQL преобразует исходный текст в исполняемую программу. SQL встроен почти во все СУБД и языки программирования, способные работать с базой данных (Delphi, FoxPro, Access и т.д.). 2.Интерактивный – имеются специальные оболочки мгновенного создания и выполнения SQL запроса. Прикладная программа, передает SQL запрос и при помощи специальных функций SQL получает результат запроса без применения перепроцесора.

Этапы выполнения операторов SQL


Nom Fam Name Grupа Predmet mark 101 Иванов Олег В-11 История 5